6066 (1960-1966) GMC Truck Club

6066 (1960-1966) GMC Truck Club (https://6066gmcclub.com/index.php)
-   Builds and Journals (https://6066gmcclub.com/forumdisplay.php?f=16)
-   -   Jethro's 1964 I1000 (https://6066gmcclub.com/showthread.php?t=51205)

Jethro September 15th, 2021 10:11 PM

Re: Jethro's 1964 I1000
 
Quick update; I got a new ignition switch to replace the janky Ace Hardware universal with the padlock looking key. Well, that opened up a whole nother can of worms. Brightly colored worms wrapped in tape up under the dash.
The farther I got into it the more problems I found. It's been quite a learning experience. I'll do a complete update in a few days or when I get done...
Stay tuned.

Jethro September 19th, 2021 05:58 PM

Re: Jethro's 1964 I1000
 
It was right before Labor day weekend and I really wanted to drive the old truck some. Just had to button up a couple things on Fri. Of course it took longer than I planned. The insurance is "suspended" so I didn't have to pay but a couple bucks a month while I've been working on her. They closed before I got there.

Seeing as I couldn't drive without insurance I figgered I'd spend some time on some small bits. Like the ignition switch. A p-o had installed a universal switch from Ace Hardware and I didn't like it. The key looked like it fit a padlock and it was ****-eyed in the dash. I had one from LMS.

When I removed the switch from the dash I just reached up behind instead of crawling under cause I'm old and don't bend well. Not sure what it looked like before I moved it but there were wires not connected and all but the pink one came off in my hand.
Here's what it looked like. The brn/white and red both fell off about 2 seconds later.


To view some links or images in this forum your post count must be 1 or greater. You currently have 0 posts. Maybe you should introduce yourself with a new topic?


Jethro September 19th, 2021 06:26 PM

Re: Jethro's 1964 I1000
 
I knew where the red, pink and purple wires go and I saw where the brn/white was before it fell off but I wasn't sure that was correct. I had no idea where the green was supposed to go. And the hardware store switch was a 4 terminal whereas the replacement was a 5 lug.

After searching the internet for a wiring diagram for hours I had no luck finding one that matched my truck. So I posted a question in the electric section of this forum. Gmcjuniorvan posted the exact diagram I needed which was very helpful. AZKen also gave me some solid advice. Thanks guys!

Long story short, I ended up with a completely disassembled dash harness finding all sorts of problems along the way. When I made it to the fuse block this is what awaited.



To view some links or images in this forum your post count must be 1 or greater. You currently have 0 posts. Maybe you should introduce yourself with a new topic?



There was a wire nut sorta connecting those 2 loose ends.


To view some links or images in this forum your post count must be 1 or greater. You currently have 0 posts. Maybe you should introduce yourself with a new topic?



Not looking good.

It seems that most of the fuse clips needed to rebuild these fuse blocks are no longer available. I searched and searched. If anyone has a source I would like to know.
Lucky for me I have a garage full of stuff. Old truck part pack rat. There's also a 66 Chevy in there.

The whole dash harness got robbed from the Chevy. I discovered that the 2 harnesses are the same at their core. The differences being extra wires on the 66 Chevy harness. Between the two I used the best parts to build one good harness for the GMC. Except one connector.
Got to rooting around in my wire box and found another partial harness that had that end. :-)

She's back alive again now. It's the weekend again. And I still didn't get the insurance turned back on. Gotta do that tomorrow. I'm itching to take her out for a spin.

Jethro September 19th, 2021 06:27 PM

Re: Jethro's 1964 I1000
 
That second pic was supposed to be this.


To view some links or images in this forum your post count must be 1 or greater. You currently have 0 posts. Maybe you should introduce yourself with a new topic?


Jethro September 20th, 2021 01:57 AM

Re: Jethro's 1964 I1000
 
AZKen linked me to a video how to clean wires with a salt and vinegar solution. Then neutralize the acid in the vinegar with a baking soda and water solution. I used it on my connectors and it worked great!

A good soak for about an hour took this


To view some links or images in this forum your post count must be 1 or greater. You currently have 0 posts. Maybe you should introduce yourself with a new topic?



To this


To view some links or images in this forum your post count must be 1 or greater. You currently have 0 posts. Maybe you should introduce yourself with a new topic?



My fuse block took a more manual approach. Ain't perfect but it is much better than before.


To view some links or images in this forum your post count must be 1 or greater. You currently have 0 posts. Maybe you should introduce yourself with a new topic?





To view some links or images in this forum your post count must be 1 or greater. You currently have 0 posts. Maybe you should introduce yourself with a new topic?



And the whole dash lights up like a Christmas tree. The key was off in this pic but the gen, oil and turn indicator bulbs all work too.


To view some links or images in this forum your post count must be 1 or greater. You currently have 0 posts. Maybe you should introduce yourself with a new topic?



Pretty sure the gas gage works now. Tomorrow I'll get the insurance turned back on and drive her.

Funky61 September 20th, 2021 05:54 PM

Re: Jethro's 1964 I1000
 
Boy Jethro that cleaned great and those dash lights have really come to life! Nice tip and video link too.

Jethro September 20th, 2021 10:12 PM

Re: Jethro's 1964 I1000
 
Yeah. I was amazed!
I'm very grateful to AZKen for that cleaning tip.

I just got back from the insurance office. Gonna take her out for a spin in a bit. First to the gas station. Might maybe even stop by the car wash. If all goes well in town we'll hit some back roads.
First I gotta get out of these work boots.

Jethro September 21st, 2021 04:00 PM

Re: Jethro's 1964 I1000
 
Well, we didn't get to the car wash but she drove great both in and out of town. Cruised right down the back country roads at 55. Man, those new shocks made a big difference!
I drove her to work today.

9 gallons of gas didn't make the fuel gage go any higher. Looks like a new sender gets added to the list. I keep forgetting to look at the temp gage until it's been running for a while. Gotta remember to check that cold.

Jethro September 28th, 2021 12:55 AM

Re: Jethro's 1964 I1000
 
Since my last update the old gal got new fluids in her tranny and rear end. Looked like it was more than due. It ain't easy to find old school lube now days!

She shifts smoother now and ain't quite as noisy going down the road. Inside the pumpkin didn't look too bad. A bit of rust pitting on the gears but I think that dog will hunt for a while yet. 3:54 gears in there.



To view some links or images in this forum your post count must be 1 or greater. You currently have 0 posts. Maybe you should introduce yourself with a new topic?



I've been looking for the elusive GMC heater knob. Pert near impossible to find.



To view some links or images in this forum your post count must be 1 or greater. You currently have 0 posts. Maybe you should introduce yourself with a new topic?



Unless, that is, you look in the ashtray! Woo-hoo!



To view some links or images in this forum your post count must be 1 or greater. You currently have 0 posts. Maybe you should introduce yourself with a new topic?



Been getting some windshield time in finally. She runs great down the back roads. Put about 150 miles on over the weekend. The last 79 miles worth I did the math... 17.1mpg! I'm surprised and really happy about that!

Drove her to work today and stopped by the car wash for a much deserved bath on the way home. Layers came off! I bet it's been years since she got washed.

Jethro September 28th, 2021 01:02 AM

Re: Jethro's 1964 I1000
 
Dang. I just realized looking at that pic of the knob from the ashtray... that probably ain't it. Looks like wipers?

Does anybody have a pic of the knob I'm looking for?


All times are GMT +1. The time now is 03:05 AM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.