6066 (1960-1966) GMC Truck Club Bitcoin now accepted here! 
Pay Dues
Pay Dues or become a Site Supporter
 



Go Back   6066 (1960-1966) GMC Truck Club > 6066 GMC Truck Club Forum > Interiors, Dash, Lights and Electrical


Interiors, Dash, Lights and Electrical Everything Inside

Reply
 
Thread Tools
  #1  
Old February 4th, 2019, 07:43 PM
GTS61 GTS61 is offline
Senior Member
 
Join Date: Jul 2014
Location: Jacksonville, Fl.
Truck: 1961 Stepside-305 V6
Age: 57
Posts: 148
Rep Power: 67
GTS61 is on a distinguished road
Default New battery and new alternator-DEAD

I installed a new battery and new alternator. It’s a 305 V6. Started it up and watched the volt gauge go from 12 to 0. Any idea’s why this would happen? Thanks
Reply With Quote
  #2  
Old February 4th, 2019, 10:26 PM
AZKen's Avatar
AZKen AZKen is offline
Senior Member
 
Join Date: Jul 2014
Location: State48
Truck: 1960 K1001 Wideside 305 BW Custom Cab
Posts: 973
Rep Power: 301
AZKen is a jewel in the roughAZKen is a jewel in the roughAZKen is a jewel in the rough
Default Re: New battery and new alternator-DEAD

Assuming you installed/wired it all up correctly, we will then have to assume a bad part or a bad battery. Does not matter if things are "new" or what the dash gauge says for now.

First thing to do is get a multimeter set on DC volts. Touch on battery posts while motor not running to see if it reads around 12.6V. Then at high'ish idle, see if it reads 14V +. Be SURE to touch the battery posts, NOT the cable clamps. Report findings.

If you don't get these voltages, clean all cable ends and battery posts (neg and pos) and cable ground locations with a good wire wheel or brush. Check all alternator connections. BE SURE there is no paint, corrosion or plating preventing the new alternator case or brackets from being grounded. Then repeat tests.

Last edited by AZKen; February 4th, 2019 at 10:38 PM.
Reply With Quote
  #3  
Old February 5th, 2019, 12:08 AM
GTS61 GTS61 is offline
Senior Member
 
Join Date: Jul 2014
Location: Jacksonville, Fl.
Truck: 1961 Stepside-305 V6
Age: 57
Posts: 148
Rep Power: 67
GTS61 is on a distinguished road
Default Re: New battery and new alternator-DEAD

Thanks Ken I found the problem. I did check the battery after charging. And with my multi meter it was reading 12.3. But the numbers touching case of alternator was the same and the truck was running. The last thing I did was take off the pos. cable off of solenoid to clean it and found a bad fitting. Runs like a kitten now!
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: [6066 GMC] Battery discharges overnight: Bad alternator? Switch? Archiver Previous Forum Posts 0 November 9th, 2009 12:51 AM
Re: [6066 GMC] Battery discharges overnight: Bad alternator? Switch? Archiver Previous Forum Posts 0 November 7th, 2009 12:53 AM
Re: [6066 GMC] Battery discharges overnight: Bad alternator? Switch? Archiver Previous Forum Posts 0 November 7th, 2009 12:53 AM
Re: [6066 GMC] Battery discharges overnight: Bad alternator? Switch? Archiver Previous Forum Posts 0 November 7th, 2009 12:42 AM
Battery discharges overnight: Bad alternator? Switch? Archiver Previous Forum Posts 0 November 7th, 2009 12:21 AM


All times are GMT +1. The time now is 12:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2013, Jelsoft Enterprises Ltd 107|0
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.